Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1005 closed Bug (fixed)

Link to Module SitesManager is not shown

Reported by: habakuk Owned by:
Priority: major Milestone: Piwik 0.4.4
Component: UI - UX (AngularJS, twig, less) Keywords: SitesManager
Cc: Sensitive: no

Description

After some automatic updates the link to the page index.php?module=AdminHome&module=SitesManager&idSite=1&period=day&date=yesterday is not available in the backend any more.

If I call it manual the site is shown.

I'm running Piwik 0.4.3

Change History (10)

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Milestone set to 2 - Piwik 0.6
  • Resolution set to invalid
  • Status changed from new to closed

There's a typo in your URL... you have the module= param twice. You'll have to update your bookmarks: AdminHome became CoreAdminHome.

comment:2 Changed 5 years ago by habakuk

Yeah, thats the problem... I have to guess the link, but I think it should be on a prominent place somewhere in the admin backend...

BTW: If the tracker shows me the buttons to reopen a issue it also should allow me to reopen it - i don't need to see them if cannot change the state!

comment:3 Changed 5 years ago by vipsoft (robocoder)

You shouldn't have to guess the link. If you click on "Settings", the admin screen has a tab for "Web Sites".

comment:4 Changed 5 years ago by habakuk

No, it hasn't I only see the list of plugins and no more links than on the main site of piwik.

comment:5 Changed 5 years ago by vipsoft (robocoder)

Please post the [PluginsInstalled] section of your config.ini.php.

Then delete config.ini.php. The Installation screen will pop up when you visit your dashboard. Here, Piwik will recreate your config.ini.php. Select "Reuse existing tables".

comment:6 Changed 5 years ago by habakuk

ok, here it is:

[PluginsInstalled]
PluginsInstalled[] = Login
PluginsInstalled[] = AdminHome
PluginsInstalled[] = UsersManager
PluginsInstalled[] = SitesManager
PluginsInstalled[] = Installation
PluginsInstalled[] = API
PluginsInstalled[] = Widgetize
PluginsInstalled[] = Home
PluginsInstalled[] = Actions
PluginsInstalled[] = Dashboard
PluginsInstalled[] = Referers
PluginsInstalled[] = UserSettings
PluginsInstalled[] = UserCountry
PluginsInstalled[] = VisitsSummary
PluginsInstalled[] = VisitFrequency
PluginsInstalled[] = VisitTime
PluginsInstalled[] = VisitorInterest
PluginsInstalled[] = ExamplePlugin
PluginsInstalled[] = Provider
PluginsInstalled[] = Feedback
PluginsInstalled[] = CoreHome
PluginsInstalled[] = CoreUpdater
PluginsInstalled[] = CoreAdminHome
PluginsInstalled[] = CorePluginsAdmin
PluginsInstalled[] = LanguagesManager
PluginsInstalled[] = Live
PluginsInstalled[] = DBStats
PluginsInstalled[] = Goals
PluginsInstalled[] = PluginsAdmin

comment:7 Changed 5 years ago by habakuk

After recreating the config.ini.php the the link is available.

comment:8 Changed 5 years ago by vipsoft (robocoder)

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:9 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

In [1504], refs #1005 - delete obsolete directories (during update process)

comment:10 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 2 - Piwik 0.6 to 1 - Piwik 0.5
Note: See TracTickets for help on using tickets.