Opened 4 years ago

Closed 23 months ago

Last modified 23 months ago

#1052 closed New feature (fixed)

Display the time that last Archive ran "Reports were generated X seconds|minutes|hours ago"

Reported by: matt Owned by:
Priority: major Milestone: 1.12.x - Piwik 1.12.x
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description (last modified by matt)

From email:

It would be nice to have some indication on the page how old the displayed data is (e.g. a running timer since last update?)

Proposal: record in the DB piwik_option table the time the last archive ran for each website, and display this information in the Admin screen in the website table, in a new column. Later, we can see how to integrate this in the user interface for all users to see. Proposed wording is "Today's reports were generated 155 seconds ago" or "Today's reports were generated 1 hour 5 minutes ago".

Change History (14)

comment:1 Changed 4 years ago by matt (mattab)

  • Description modified (diff)

comment:2 Changed 4 years ago by matt (mattab)

maybe this could be displayed in the 'General settings' page, as it would be contextual with the settings available on this page (setup today's archive time to live)

comment:3 Changed 4 years ago by matt (mattab)

  • Milestone changed from 4 - Piwik 1.0 - Stable release to Features requests - after Piwik 1.0

comment:4 Changed 4 years ago by matt (mattab)

  • Priority changed from major to low

comment:5 Changed 3 years ago by matt (mattab)

  • Priority changed from low to critical

I think this is a must have now, also to work around #373

when we are look at "Today" or "current week/month/year", the UI should show the time the report was generated.

"Report generated 15 minutes ago."

increasing priority since it is easy to implement, and will help a ton with user support, since #373 is confusing to everyone and we often have to explain. I think this sentence will at least help them understand

While we do this, we could also log the output in a file and show the last lines? or record last N output in DB and read from there?

See #2473

comment:6 Changed 3 years ago by matt (mattab)

  • Milestone changed from Feature requests to 1.7 Piwik 1.7

comment:7 Changed 2 years ago by matt (mattab)

  • Priority changed from critical to major

comment:8 Changed 2 years ago by matt (mattab)

  • Milestone changed from 1.9 Piwik 1.9 to 1.8.x - Piwik 1.8.x

comment:9 Changed 23 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [6331]) Fixes #1052, added message describing when a report was archived to the report documentation in all table reports.

Notes:

  • Added ability to associate metadata with DataTable instances.

comment:10 Changed 23 months ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

Nice idea!

  • I notice the time does not display in the Pages titles/urls/entry/exit reports?

comment:11 Changed 23 months ago by matt (mattab)

(In [6335]) Refs #1052

  • CSS updates
  • refactored since there is already a function doing this code ;)

comment:12 Changed 23 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6337]) Fixes #1052, added report generated on message to actions datatable.

comment:14 Changed 23 months ago by capedfuzz (diosmosis)

(In [6339]) Refs #1052, fix regression, other data table types dont have 'dataTable' css class.

Note: See TracTickets for help on using tickets.