Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1100 closed Bug (fixed)

Warning messages on empty dashboard

Reported by: thilo Owned by: matt
Priority: normal Milestone: Piwik 0.5.5
Component: Core Keywords: empty dashboard
Cc: Sensitive: no

Description

this warning

Warning: Invalid argument supplied for foreach() in ..../piwik/plugins/Dashboard/Controller.php on line 151

shows up for each empty dashboard column; so if one column has a widget there are two warning messages, 2 widgets on 2 different columns gives only 1 warning - no widgets at all shows 3 messages.

using latest version 0.5.4

Change History (3)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Milestone set to 1 - Piwik 0.5.5
  • Owner set to matt

Is this a new install?

This shouldn't be possible if the dashboard layout was saved correctly.

comment:2 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1809]) fixes #1100 - handle malformed dashboard layout

comment:3 Changed 4 years ago by vipsoft (robocoder)

Post-note: the cause was json_decode() for an empty array element ('[]') did not return array().

Note: See TracTickets for help on using tickets.