Opened 4 years ago

Closed 4 years ago

#1256 closed Bug (fixed)

Super user login can contain special characters

Reported by: renelux Owned by:
Priority: major Milestone: Piwik 0.6
Component: Core Keywords:
Cc: Sensitive: no

Description

My archive.sh doesn't retrieve the authkey in a proper way. I think that this has something to do with the superuser login name.

Username plain: René Lux
Username config: René Lux

The problem is temporary fixed by hardcoding it.

Change History (3)

comment:1 Changed 4 years ago by matt (mattab)

  • Milestone set to 1 - Piwik 0.6

comment:2 Changed 4 years ago by matt (mattab)

  • Summary changed from archive.sh doesn't retrieve proper auth_key to Super user login can contain special characters

comment:3 Changed 4 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [2068]) Fixes #1256 Installer now checks that the super user is a valid login string (no special letters, no space, etc.)

Note: See TracTickets for help on using tickets.