Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1326 closed Bug (fixed)

Installation failed on step 7

Reported by: skid Owned by:
Priority: critical Milestone: Piwik 0.6
Component: Core Keywords:
Cc: Sensitive: no

Description

On 7 step I've got following error message "- You can't access this resource as it requires an 'admin' access for at least one website."

Even if I try to use "example.org" or my own domain.
Tried to use svn version and lates.zip without result, same error.

Change History (8)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Keywords installation error admin access removed

This appears to be the problem behind the failing webtest.

comment:2 Changed 4 years ago by vipsoft (robocoder)

  • Priority changed from major to critical

comment:3 Changed 4 years ago by matt (mattab)

I broke that.. let me fix it

comment:4 Changed 4 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [2138]) Fixes #1326
checkUserHasSomeAdminAccess() fails when there is no website yet. Making it work if user is super user.

comment:5 Changed 4 years ago by matt (mattab)

(In [2140]) 0.6 with fix #1326

comment:6 Changed 4 years ago by matt (mattab)

This was introduced in [2124]

I republished 0.6 with the fix in it, hopefully not many users did have time to download 0.6

comment:7 Changed 4 years ago by vipsoft (robocoder)

Thanks Matt.

For consistency, can we similarly patch checkUserHasAdminAccess()?

comment:8 Changed 4 years ago by matt (mattab)

checkUserHasAdminAccess is slightly different as it is used to actually check also that the idsites provided are correct and exist (eg. in SitesManager.updateSite).

If we change checkUserHasAdminAccess we would need to check that all methods would not fail or misbehave when give one or a list of fake website IDs. but agreed, this would be consistent and good todo :)

Note: See TracTickets for help on using tickets.