Opened 4 years ago

Closed 4 years ago

#1357 closed Bug (fixed)

endless HTTP 302 Moved Temporarily loop instead of login form

Reported by: dysolution Owned by:
Priority: normal Milestone: Piwik 0.6.4
Component: Core Keywords:
Cc: Sensitive: no

Description

On a relatively new installation of Piwik 0.6.1, I had configured "For anonymous users, report date to load by default" to be "Current Week". This resulted in all visitors attempting to access Piwik (login form) receiving an endless loop of HTTP 302 redirects. The login form does not even appear.

I do not have any web sites configured to allow viewing by anonymous users; this setting remained from previous testing when I had a web site with anonymous viewing enabled. I didn't think this setting should matter because of the note "Note: You do not have any website that the anonymous user can access, the following settings won't be used." above the Anonymous user settings area.

However, switching it back to make "Today" the default anonymous destination fixed the issue and allowed the login form to appear.

Change History (3)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Keywords 302 HTTP redirect temporarily moved anonymous login removed
  • Milestone set to 0 - Piwik 0.6.2

comment:2 Changed 4 years ago by vipsoft (robocoder)

  • Priority changed from major to normal

comment:3 Changed 4 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [2498]) Fixes #1357 - when the request is invalid, users are now redirected to the Login form. Relogging will ensure that the right website is selected.

Thanks for the report dysolution

Note: See TracTickets for help on using tickets.