Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1378 closed Bug (fixed)

PHP 5.1.6 notices and errors

Reported by: vipsoft Owned by: vipsoft
Priority: major Milestone: Piwik 0.6.2
Component: Core Keywords:
Cc: Sensitive: no

Description

Reported on forum http://forum.piwik.org/index.php?showtopic=9651

Fatal error: Call to a member function getColumn() on a non-object in /PATH/core/DataTable/Filter/Sort.php on line 120

Unit tests:

Exception: ../tests/core/DataTable.test.php -> Test_Piwik_DataTable -> test_getLastRow -> Unexpected PHP error [Object of class Piwik_DataTable_Row to string conversion] severity [E_NOTICE] in [/PATH/tests/simpletest/test_case.php line 312]

and:

Fatal error: Call to undefined function json_encode() in /PATH/core/DataTable/Renderer/Json.php on line 39

Change History (11)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Owner set to vipsoft

comment:2 Changed 4 years ago by vipsoft (robocoder)

Added libs/upgradephp/upgrade.php to config_test.php. Additional errors:

Fail: ../tests/core/TablePartitioning.test.php -> Test_Piwik_TablePartitioning -> test_noTable -> Equal expectation fails at character 0 with [piwik_archive_numeric_2000_09] and [Object id #358] at [PATH/tests/core/TablePartitioning.test.php line 51]
Fail: ../tests/core/TablePartitioning.test.php -> Test_Piwik_TablePartitioning -> test_monthlyPartition -> Equal expectation fails at character 0 with [piwik_archive_numeric_2000_09] and [Object id #1295] at [PATH/tests/core/TablePartitioning.test.php line 71]
Fail: ../tests/core/TablePartitioning.test.php -> Test_Piwik_TablePartitioning -> test_dailyPartition -> Equal expectation fails at character 0 with [piwik_archive_numeric_2000_09_10] and [Object id #997] at [PATH/tests/core/TablePartitioning.test.php line 91]

Fail: ../plugins/SitesManager/tests/SitesManager.test.php -> Test_Piwik_SitesManager -> test_setDefaultTimezoneAndCurrencyAndExcludedQueryParametersAndExcludedIps -> Equal expectation fails as [Object: of Piwik_Date] does not match [String: 2010-05-27] at [PATH/plugins/SitesManager/tests/SitesManager.test.php line 783]

Exception: ../plugins/SitesManager/tests/SitesManager.test.php -> Test_Piwik_SitesManager -> test_setDefaultTimezoneAndCurrencyAndExcludedQueryParametersAndExcludedIps -> Unexpected PHP error [Object of class Piwik_Date could not be converted to int] severity [E_NOTICE] in [PATH/tests/simpletest/expectation.php line 246]

comment:4 Changed 4 years ago by vipsoft (robocoder)

(In [2221]) refs #1378 - fix assert typos

comment:7 Changed 4 years ago by vipsoft (robocoder)

Unable to reproduce the "Call to a member function getColumn() on a non-object in /PATH/core/DataTable/Filter/Sort.php on line 120" error, selecting days and/or periods with/without visits.

comment:8 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 4 years ago by vipsoft (robocoder)

(In [2225]) refs #1378 - check return value from current() for failure

comment:11 Changed 4 years ago by vipsoft (robocoder)

Typo in last commit... meant this ticket #1387.

Note: See TracTickets for help on using tickets.