Opened 4 years ago

Closed 2 weeks ago

#1434 closed New feature (answered)

Goal Tracking plugin list of feature requests

Reported by: matt Owned by:
Priority: major Milestone: Future releases
Component: Core Keywords:
Cc: Sensitive: no

Description (last modified by matt)

In #774, the first stable release of the Goal Tracking plugin was released in Piwik. We have other ideas of improvements to the plugin:

Create Goal options

  • Currently, only one goal conversion can be triggered per visit. Add an option, per goal, to allow recording multiple conversion per visit for this goal. (Implemented in #2258.)
  • it could be possible to trigger a goal based on a Page title (currently done on URL) (implemented in #2293)
  • There should be an easy way to test a URL against the regex : When entering the regex to detect as a goal, we could query the piwik API for this regex and autocomplete the list all URLs that match the regex; allows for an easy debug/check that the regex is correct and will be triggered when expected
    • use case for "multiple conversions per visit": if goal is 'add product to cart' then we want to track multiple conversions (with custom revenue) per visit. See #898


As suggested in forum post:

  • Add a new field in the Goal Create form "Also create this goal in the following websites: []" that would let a user select the websites on which to create the same goal, as well as the currently selected website.

Reporting & UI

  • GeoIp compatibility, archive goals by city, country? see archiveDayAggregateGoals and ticket #45
  • Add visits with conversion sparkline in the VisitsSummary overview
  • In the Goal Reports, under "Conversions Overview" listing the top 3 converting items in a segment, add a 'view more' link that would
    • load the requested table below
    • move the cursor to the top of the table
    • if possible, have this data in the hash so that the URL can be passed around ("Check out the top keyword for our 'Checkout' goal!")

Change History (23)

comment:1 Changed 4 years ago by matt (mattab)

  • Description modified (diff)

comment:2 Changed 4 years ago by matt (mattab)

  • Description modified (diff)

comment:3 Changed 4 years ago by vipsoft (robocoder)

The Goals report currently shows:

  • segment
  • visits
  • conversions
  • conversion rate
  • revenue per visit
  • conversion rate (what's this?)
  • value per visit (which looks a lot like revenue per visit... bug?)

Kim Dushinski's "The Mobile Marketing Handbook" gives a more elaborate campaign breakdown that would require ad server integration (to determine the number of ad impressions delivered, and cost of the campaign), and allowing multiple goal conversions per visitor, e.g.,

Ad impressions                                100000
Ad click-through rate (%)                         5%
Visitors                                        5000
Conversion rate (e.g., request coupon)           15%
Conversions                                      750

Conversion rate (e.g., coupon redemptions)       33%
Conversions                                      250

Average revenue per conversion                   $10
Total revenue                                  $2500

Ad cost                                        $1000
Profit (Loss)                                  $1500

comment:4 Changed 4 years ago by matt (mattab)

  • Description modified (diff)

comment:5 Changed 4 years ago by matt (mattab)

Maybe we could disable adding goals as submenus when there are more than N goals (N to be defined) ?

comment:8 Changed 3 years ago by matt (mattab)

  • Description modified (diff)
  • Priority changed from major to critical

comment:9 Changed 3 years ago by Gorkde

comment:10 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:11 Changed 3 years ago by matt (mattab)

Schema:

  • log_conversion.url could be idaction and link to the lookup table
  • log_conversion.referer_visit_server_date could be removed (unused and duplicate of idvisit)

New report

  • we could easily add a report 'Days to conversion' that would give how many days it takes for a unique visitor from first visit to conversion to a goal. Schema would add a 'referer_days_ago' field

New report (not possible with current data or without a costly query)

  • an interesting new report to would be: #584 'Visits before conversion'. we would need to keep a counter in the log_visit table of the number of visits of this visitor, or even better (?)
  • keep a counter in new table log_visitors, that would have visitorid field, visits, last_visit_time. This new table could also be used to process unique visitors across any period of time, not just months
    • Also useful for #584 "Visits since last conversion"
    • Also useful for #2031 "Days since last conversion"
    • Also could be used to store the first referer URL for conversions attribution, they are now stored in 1st party cookies but it is not ideal, see comment.

See this post to learn more about these reports: http://www.kaushik.net/avinash/2006/08/excellent-analytics-tip6-measure-days-visits-to-purchase.html

comment:12 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:13 Changed 3 years ago by matt (mattab)

  • Milestone changed from Feature requests to 1.x - Piwik 1.x
  • Priority changed from critical to major

comment:14 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

Moved some requirements to specific tickets: #2029, #2030, #2031

comment:15 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:16 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:17 Changed 3 years ago by matt (mattab)

For "manual goal conversion", we could also put a code snippet that shows how to trigger a Goal on form submit, as it is a common use case, and technical enough to do that many users can't do it out of the box. Would be great to have the help right in the Goal create/edit UI.

comment:18 Changed 3 years ago by vipsoft (robocoder)

re: onsubmit. Will have to see if Webkit bug 54783 affects this too.

comment:19 Changed 3 years ago by vipsoft (robocoder)

  • Description modified (diff)

comment:20 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:21 Changed 3 years ago by matt (mattab)

  • Milestone changed from 1.x - Piwik 1.x to Feature requests

comment:22 Changed 2 years ago by mattcowan

For users who have set multiple goals, add an option to assign each goal a different colored flag instead of a default green one so that the user can quickly tell which goal was achieved on the visitor log without having to hover over the flag.

comment:23 Changed 2 weeks ago by matt (mattab)

  • Resolution set to answered
  • Status changed from new to closed

Closing this ticket as it seems mostly empty now that we've implemented most ideas listed here. Feel free to create a ticket for specific improvements to Goal plugin!

Note: See TracTickets for help on using tickets.