Opened 4 years ago

Closed 4 years ago

#1495 closed Bug (fixed)

0.6.4 - HTML_QuickForm2 incompatible with PHP 5.1.6

Reported by: vipsoft Owned by: vipsoft
Priority: critical Milestone: Piwik 0.6.5
Component: Core Keywords:
Cc: Sensitive: no

Description

Fatal error: Call to protected method HTML_QuickForm2_Renderer_Array::exportMethods() from context 'HTML_QuickForm2_Renderer_Proxy' in /var/www/html/piwik/libs/HTML/QuickForm2/Renderer/Proxy.php on line 113

http://forum.piwik.org/index.php?showtopic=12211

Change History (3)

comment:1 Changed 4 years ago by vipsoft (robocoder)

This is a known incompatibility in HTML_QuickForm2. http://pear.php.net/bugs/bug.php?id=14110. Hence, HTML_QuickForm2 now requires php 5.2+.

The cause is a bug in php 5.0.x/5.1.x. See http://bugs.php.net/bug.php?id=37632 and http://bugs.php.net/bug.php?id=37212. This is worrisome because Piwik uses "protected" access in many places.

comment:2 Changed 4 years ago by vipsoft (robocoder)

  • Summary changed from 0.6.4 - regression with PHP 5.1.6 to 0.6.4 - HTML_QuickForm2 incompatible with PHP 5.1.6

comment:3 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [2626]) quick fixes #1495 - change protected to public

Note: See TracTickets for help on using tickets.