Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1570 closed Bug (fixed)

Goals Loading... never stops

Reported by: vipsoft Owned by:
Priority: critical Milestone: Piwik 0.9.9 - Stable release
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description (last modified by vipsoft)

In 0.9, with Firefox 3.6.8.

Starting with no goals, if I create a goal, the "Loading" icon spins and the screen doesn't refresh. The menu only shows "Add a new goal". The new goal isn't shown but is in the database and in tmp/cache/tracker/1.php.

Only a manual refresh or switching between top menu bar screens, does the superfish menu update to show: "Overview" and the new goal.

Similar problem if editing a goal, but not when deleting.

Change History (9)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Component changed from Core to UI (templates, javascript)

comment:2 Changed 4 years ago by matt (mattab)

I think this is due to missing permissions in tmp/cache/tracker/

The goal create should update the cache file there, which is then read by UI to show submenus for each goal. I don't think we currently check that tmp/cache/tracker is writable so there is a buggy edge case there maybe?

comment:3 Changed 4 years ago by vipsoft (robocoder)

My files are up-to-date and the permissions are correct. I was reproducing the problem reported in the forum.

comment:4 Changed 4 years ago by matt (mattab)

vipsoft, if you delete files in tmp/cache/tracker, do you still only see "Add a new goal" ? If the goal is recorded in the DB, this is definitely a new bug...

comment:5 Changed 4 years ago by vipsoft (robocoder)

  • Description modified (diff)

comment:6 Changed 4 years ago by vipsoft (robocoder)

ah... found the problem... if 'updated=1' is already in the url, subsequent changes to goals doesn't refresh the screen

comment:7 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [2917]) fixes #1570 by incrementing update counter

comment:9 Changed 4 years ago by matt (mattab)

  • Summary changed from Goals - broken menu navigation? to Goals Loading... never stops
Note: See TracTickets for help on using tickets.