Opened 4 years ago

Closed 4 years ago

#1614 closed Bug (fixed)

Android OutOfMemory error

Reported by: tsteur Owned by: tsteur
Priority: major Milestone: Piwik Mobile Client
Component: Core Keywords: android defect outofmemory
Cc: Sensitive: no

Description

If the user changes the view about 12-15 times on an Android device, we get an OutOfMemory error. There is a memory leak in the Titanium Mobile SDK when closing and opening windows, see https://appcelerator.lighthouseapp.com/projects/32238/tickets/1432-android-outofmemory-issue

Change History (2)

comment:1 Changed 4 years ago by tsteur

  • Status changed from new to assigned

Seems to be fixed in latest Titanium Build (rce81f4e0). Can not reproduce it. Changed the window more than 30 times and it works great. No OutOfMemory error. I'll watch over it in the next days.

comment:2 Changed 4 years ago by tsteur

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in latest Titanium build

Note: See TracTickets for help on using tickets.