Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#1632 closed New feature (fixed)

PDFReports: should be translated to the user's language

Reported by: hpatay Owned by:
Priority: normal Milestone: Piwik 1.1
Component: Core Keywords: plugin pdf reports language
Cc: Sensitive: no

Description

In the GUI of Piwik one is able to switch the language, but when automatic
reports are generated and sent in PDFReports, only the default language is used.
It might be better to extend the UI of PDFReports with a language selection box and the corresponding database table with a new lang column.
Workaround: set the language in archive.sh (but this should not be the solution...)

Change History (9)

comment:1 follow-up: Changed 4 years ago by matt (mattab)

If not the case, PDF reports should be sent in the user's language who created the PDF report.

comment:2 Changed 4 years ago by matt (mattab)

  • Milestone changed from Plugin Repository to 5 - Piwik 1.1

comment:3 in reply to: ↑ 1 Changed 4 years ago by hpatay

Replying to matt:

If not the case, PDF reports should be sent in the user's language who created the PDF report.

Maybe this is not possible without adding the language to the pdf table, because the scheduled tasks are activated by archive.sh which only knows about the superuser.

comment:4 Changed 4 years ago by matt (mattab)

  • Summary changed from PDFReports lacks multi language feature on automatic reporting via email to PDF Reports should be the user's language

comment:5 Changed 4 years ago by matt (mattab)

  • Summary changed from PDF Reports should be the user's language to PDF Reports should be in the user's language

comment:6 Changed 4 years ago by vipsoft (robocoder)

  • Summary changed from PDF Reports should be in the user's language to PDFReports: should be translated to the user's language

Also reported in http://forum.piwik.org/index.php?showtopic=13741 ... marking #1563 as a dupe of this ticket.

comment:7 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3470]) Fixes #1632

  • simplifying language loading code
  • PDFs are now generated in the user language, as well as the email subject/content

comment:9 Changed 3 years ago by matt (mattab)

  • Type changed from Bug to New feature
Note: See TracTickets for help on using tickets.