Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#1648 closed New feature (fixed)

Stay on "Email Reports" page after switching website

Reported by: Beatgarantie Owned by: SteveG
Priority: low Milestone: Piwik 1.1
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

after switching the website report page should be shown again.

Change History (9)

comment:1 Changed 4 years ago by vipsoft (robocoder)

  • Milestone changed from 4 - Piwik 1.0 to 5 - Piwik 1.1

For consistency, perhaps it should always reload the current form when changing the website. (Similarly for language.)

comment:2 Changed 4 years ago by SteveG (sgiehl)

has anyone already worked on this ticket? works for me with current trunk.

comment:3 Changed 4 years ago by Beatgarantie

I am very pleased to hear that it works with the trunk. With 1.0 I am confronted with this issue.

comment:4 Changed 4 years ago by matt (mattab)

on trunk, it works for anonymous (redirect to same page again after changing website), but doesn't work when logged in (redirect to dashboard after changing website).

comment:5 Changed 4 years ago by SteveG (sgiehl)

Works for me for the superuser, too. Will have to test it with another user...

comment:6 Changed 4 years ago by SteveG (sgiehl)

  • Owner set to SteveG

Ok. checked that again. This behaviour seems to occure ONLY if autocomplete is enabled in website selection (more than 10 websites). I will have a closer look a this.

comment:7 Changed 4 years ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3030]) fixes #1648 stay on current page (with new siteid) on selection in autocomplete

comment:8 Changed 4 years ago by SteveG (sgiehl)

Is there a bug in autocomplete? when I type something into the searchbox, there are html-tags outputed within the results. seems to be the response is escaped before it is inserted to dom.

comment:9 Changed 3 years ago by matt (mattab)

Steve, autocomplete seems to work OK for me. Can you maybe try again and create a new ticket if you see errors?

Note: See TracTickets for help on using tickets.