Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1817 closed New feature (fixed)

Hide backtrace from error messages in Tracker

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.1
Component: Core Keywords:
Cc: Sensitive: no

Description

Have errors only show the error message by default, but no backtrace.

Include an inline help to explain how to enable backtrace info in the error message.

When $GLOBALS[PIWIK_TRACKER_DEBUG] is true, display the backtrace.

Change History (2)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3316]) fixes #1817 - added Piwik_Tracker_ExitWithException(); also fixed a regression where db exceptions were not being caught because the adapters no longer throw PDOException

comment:2 Changed 3 years ago by matt (mattab)

Thanks vipsoft!

Note: See TracTickets for help on using tickets.