Opened 3 years ago

Closed 3 years ago

#1904 closed Bug (fixed)

MultiSites Plugin Error

Reported by: eistrati Owned by:
Priority: normal Milestone: Piwik 1.1.1
Component: Core Keywords:
Cc: Sensitive: no

Description

Every time when I run http://analytics.mysite.com/index.php?module=MultiSites&action=index&idSite=1&period=day&date=today, I found a lot of errors in my log file (see one example in the attachment). I was trying to debug the code (all errors are related to lines 78 - 83 in plugins/MultiSites/Controller.php), but don't have the time luxury, so please help me understand this issue and potentially solve it.

Attachments (1)

error.txt (1.4 KB) - added by eistrati 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by eistrati

comment:1 Changed 3 years ago by matt (mattab)

  • Milestone set to 1.2 - Piwik 1.2

what version of Piwik are you using?

comment:2 Changed 3 years ago by eistrati

1.0

comment:3 Changed 3 years ago by vipsoft (robocoder)

What about your PHP version? I have E_STRICT (2048) here, and I'm not seeing those error messages.

comment:4 Changed 3 years ago by vipsoft (robocoder)

What if you change array_shift() to reset() ?

comment:5 Changed 3 years ago by vipsoft (robocoder)

or current() ?

comment:6 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3516]) fixes #1904 - worksforme (must be php version specific); modify code to use a temporary variable

Note: See TracTickets for help on using tickets.