Opened 3 years ago

Closed 3 years ago

#1948 closed Task (fixed)

Tracker: review Smartbot filter for Live/Bing

Reported by: vipsoft Owned by:
Priority: normal Milestone: 1.5 - Piwik 1.5
Component: Core Keywords:
Cc: Sensitive: no

Description

In [3155], we added a filter based on the User-Agent.

However, BadBehaviour continues to release updates based on IP ranges (using CIDR notation), i.e.,

  • 207.46.0.0/16
  • 65.52.0.0/14
  • 207.68.128.0/18
  • 207.68.192.0/20
  • 64.4.0.0/18
  • 157.54.0.0/15
  • 157.60.0.0/16
  • 157.56.0.0/14

We need to verify that our filter still works.

Change History (3)

comment:1 Changed 3 years ago by matt (mattab)

Maybe, this is a quick fix now that CIDR notation is supported? or maybe we don't really care since it is not an issue and maybe we should not trust badbehavior db anyway!

comment:2 Changed 3 years ago by vipsoft (robocoder)

before adding any of the ip ranges used by badbehavior, we'll verify the netblock belongs to Google/Bing/etc

comment:3 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4784]) fixes #1948 - confirmed these are Microsoft assigned netblocks; should we incubate the BotTracker in #2391 to takeover the smartbot filtering?

Note: See TracTickets for help on using tickets.