Opened 3 years ago

Closed 3 years ago

#1949 closed Bug (fixed)

Bug in yearly archiving in very rare case

Reported by: matt Owned by: matt
Priority: normal Milestone: Piwik 1.2
Component: Core Keywords:
Cc: Sensitive: no

Description

There is one (to be identified) use case where the yearly archiving fails. See output of archiving:

# grep error archive_output -B4

--
</results>
Archiving period = year for idsite = 5...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 6...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 21...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 32...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 35...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 36...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 60...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 61...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />
--
</results>
Archiving period = year for idsite = 97...
<?xml version="1.0" encoding="utf-8" ?>
<result>
        <error message="You are requesting a precise subTable but there is not such data in the Archive." />

Change History (1)

comment:1 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3752]) Fixes #1949 Not throwing the exception if the requested subtable not found, but returning empty datatable, I was unable to know in which cases it throws the error, but only saw it once with a 10G piwik log_* db...

Note: See TracTickets for help on using tickets.