Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2076 closed Bug (fixed)

Visitor Log month view is incomplete

Reported by: monnerat Owned by:
Priority: normal Milestone: Piwik 1.2
Component: Core Keywords:
Cc: Sensitive: no

Description

As stated in the summary, I only see one day when selecting a month view. The data export function also exports a single day.

From what I can see, this is a timezone problem (I'm east of UTC). It is not clear if the designer's intention were to show an UTC month or a localtime month, but there is some inconsistencies in date handling:
The month start date is taken as UTC first, then copied to some other object and associated to the local timezone, resulting in a local date being the last day of the previous month (for east of UTC). When we establish the list of target date, days are added one by one until the LOCAL TIME month changes: this is immediate.

The correct fix is not obvious: it depends on what is intended (target is UTC or localtime month). I have implemented a fix at the date conversion level, assuming locatime month range is targeted. May be it's not optimal (date handling should be probably changed and/or fully explained), but it allows a full month view.

Attachments (1)

piwik-1.1.1-tzbug.patch (1.2 KB) - added by monnerat 3 years ago.
Patch for Piwik 1.1.1

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by monnerat

Patch for Piwik 1.1.1

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Milestone set to 1.2 Piwik 1.2

dupe of #1873?

comment:2 Changed 3 years ago by matt (mattab)

(In [3920]) Fixing typo in date->setDay - thanks monnerat for patch Refs #2076

comment:3 Changed 3 years ago by matt (mattab)

In current trunk, I think it is working, however the "Next" link at the bottom loads an empty page, but there are more visits. was it working in 1.1?

comment:4 Changed 3 years ago by matt (mattab)

monnerat, if you could try current trunk and see if the bug if fixed, that would be very useful

comment:5 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3922]) Fixes #2054, #2076, #1947

  • Visitor Log: offset now removed from Live API all together. As a result, Previous< in the datatable footer will return to the start, this could be improved but OK for now. Offset for next is the ID Visit as before
  • Live! widget: offset is now the timestamp, so the request hits the INDEX
  • This should fix most of the reordering bug: well now it should load on the top, the visits that have been updated since last refresh, and it deletes previous visit rows that are being updated

comment:6 Changed 3 years ago by monnerat

Piwik 1.2 fixes this issue for browser views, but not for exports ...

comment:7 Changed 3 years ago by monnerat

Forget the previous comment: export output seems to always be limited to 20 rows... I think it's another bug :-(

comment:8 Changed 3 years ago by vipsoft (robocoder)

Refer to #2145 for issues/regressions that require re-investigation.

Note: See TracTickets for help on using tickets.