Opened 3 years ago

Closed 3 years ago

#2099 closed New feature (fixed)

UserAgentParser: misdetect Shiira and Safari

Reported by: vipsoft Owned by:
Priority: normal Milestone: Piwik 1.2
Component: Core Keywords:
Cc: Sensitive: no

Description

Shiira 2.2 (a Japanese WebKit based browser) is misdetected as Safari 1.2 (which is actually the webkit version used by Safari 3.2.3)

  • Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/525.28.3 (KHTML, like Gecko) Shiira Safari/125

During my testing, I found Safari would sometimes (spurious, as I have difficulty reproducing) send a truncated User Agent, e.g.,

  • Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/533.19.4 (KHTML, like Gecko)

Change History (1)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [3950]) fixes #2099 - treat Shiira as Safari since Shiira uses the installed version of Safari's webkit; for truncated UA, use the AppleWebKit version for detection

Note: See TracTickets for help on using tickets.