Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#2147 closed Bug (fixed)

Visitor countries widget displays UserCountry_country_Others

Reported by: kip Owned by: vipsoft
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description

I am using the Visitor Countries widgit. It displays all countries correctly, save one, UserCountry_country_Others - whatever that is. I am using Piwik 1.2 with the latest GeoIP plugin.

See attachment.

Attachments (1)

index.png (12.8 KB) - added by kip 3 years ago.
Visitor countries widget screenshot

Download all attachments as: .zip

Change History (15)

Changed 3 years ago by kip

Visitor countries widget screenshot

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Milestone set to 1.3 - Piwik 1.3

Is this GeoIP-specific? It doesn't appear to be occurring in trunk.

comment:2 Changed 3 years ago by kip

I don't know. Running this through source doesn't come up with anything, so I am assuming it is generated at runtime:

$ egrep -irn "UserCountry_country_" *

comment:3 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4145]) fixes #2147 - default to unknown country if not set

comment:5 Changed 3 years ago by vipsoft (robocoder)

  • Keywords UserCountry_country_Others removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

reopening: regression when GeoIP not installed.

comment:6 Changed 3 years ago by vipsoft (robocoder)

  • Owner set to vipsoft
  • Status changed from reopened to new

comment:7 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4273]) refs #2231, fixes #2147

comment:8 Changed 3 years ago by kip

Just installed 1.3. Still seeing the same problem.

comment:9 Changed 3 years ago by vipsoft (robocoder)

re: comment:8 The above fixes only apply to new visits; it doesn't correct (or apply to) previously tracked visits (i.e., already archived), and it doesn't fix the problem when using the GeoIP plugin's geoipUpdateRows.php script.

comment:10 Changed 3 years ago by kip

vipsoft: It's ok if the fix isn't retroactive. It doesn't matter to me, as long as its fixed forward.

comment:11 Changed 2 years ago by kip

vipsoft: I still am seeing UserCountry_country_Others in the Visitors country pie chart. I am using Piwik 1.6.

comment:12 Changed 2 years ago by vipsoft (robocoder)

If it's a quick fix, I'll update the geoip plugin.

Otherwise I'll defer since we're integrating geolocation into Piwik core.

comment:13 Changed 2 years ago by kip

Thanks a lot vipsoft. It's been bugging me for over a year now.

comment:14 Changed 2 years ago by kip

Hey vipsoft. I'm using 1.7.1 and I am still seeing the UserCountry_country_Others string in the visitor pie chart.

Note: See TracTickets for help on using tickets.