Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2155 closed Bug (fixed)

Automatic PDF email report not working when PDF report is linked to deleted site

Reported by: matt Owned by: matt
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description (last modified by matt)

A few users in the forums are having issues with Emails with PDF reports not sent automatically, when cron is not setup.

http://forum.piwik.org/read.php?2,72692

Piwik tries to trigger the PDF emails automatically in the Task Scheduler.

We should make it easy to enable Debug information, and log it in a file with the current date in the filename, in piwik/tmp/

Then users could send us their log files when having specific problems like this one.

Logging might have to be customized by module to limit noise. For example, enable debug logging only for "TaskShedule" hook, or class.

THis ticket is about

  • implementing better log in file feature
  • add logging for at least the PDF emails to find the bug
  • fix an issue or find out about a possible webhost limitation

Change History (5)

comment:1 Changed 3 years ago by matt (mattab)

another report (there are many like this one...) http://forum.piwik.org/read.php?2,73622

comment:2 Changed 3 years ago by matt (mattab)

  • Description modified (diff)
  • Summary changed from Add better logging for diagnose Emails not sent to Automatic email report not working without cron

comment:3 Changed 3 years ago by matt (mattab)

  • Owner set to matt

I'm pretty sure this is the bug caused by #2314. Fixing #2314 is fine, but won't solve it for existing users that have reports for deleted sites, so let's fix this issue separately here

comment:4 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4458]) Fixes #2155 by joining PDF and website table

comment:5 Changed 3 years ago by matt (mattab)

  • Summary changed from Automatic email report not working without cron to Automatic PDF email report not working when PDF report is linked to deleted site
Note: See TracTickets for help on using tickets.