Opened 3 years ago

Closed 3 years ago

#2180 closed Bug (fixed)

Regression in menu code: double click show orange warning message

Reported by: matt Owned by:
Priority: major Milestone: Piwik 1.3
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

If you click on dashboard, in the menu, more than once, the orage warning message says "Oops… problem during the request, please try again." and fades out 2s later, after the content loaded, (causing the page to jump). I'm pretty sure this is a regression.

Solution: 2 clicks on the same menu /submenu should not trigger more than 1 ajax requests...

Change History (2)

comment:1 Changed 3 years ago by SteveG (sgiehl)

The problem is, that the first request is aborted, resulting in the error message to be displayed. Maybe hiding the error message on starting the new request could fix the issue.

Adding a

piwikHelper.hideAjaxError('loadingError');

at the beginning of broadcast.loadAjaxContent should help.

comment:2 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4148]) Fixes #2180 Kuddos SteveG!

The message still shows when we click on top right "Settings" while dashboard widgets still loading... but I'm not sure how we could prevent this one (or that it matters so much)

Note: See TracTickets for help on using tickets.