Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2202 closed Bug (fixed)

Encoding errors in language files

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description

The French language file in 1.2.1 contains encoded entities:
d'entrer

It might be because on my windows box (which I use to grab the cleaned translation files after the unit test languagesManager.test.php has ran) the addcslashes or something else encodes these entities.

The other problem is the failing test, which doesn't fail on my box
http://qa.piwik.org:8080/webtest/003_UnitTests/001_response_invoke.html

Proposed solution: the languages manager test should remove entities from the language files when cleaning them up before the release.


Change History (5)

comment:1 Changed 3 years ago by vipsoft (robocoder)

The first problem: a change in TranslationsAdmin or how you get the original translation files from Noah?

The second problem: I didn't figure out the cause but I'll merge my "tidy" code into the LanguagesManager and TranslationsAdmin.

comment:2 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4149]) Fixes #2202 Now converting all entities to their characters when cleaning up translation files before release

One side effect is that & is now & only (which I rememberr fails W3C recommendations... but hey at least it's working!

comment:3 Changed 3 years ago by vipsoft (robocoder)

(In [4154]) refs #2202 - debug failing unit test

comment:4 Changed 3 years ago by vipsoft (robocoder)

(In [4155]) refs #2202 - more debug

comment:5 Changed 3 years ago by matt (mattab)

  • Priority changed from critical to normal
Note: See TracTickets for help on using tickets.