Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2218 closed Bug (fixed)

Fatal error in API response "Maximum function nesting level of '100' reached, aborting!"

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Change History (6)

comment:1 Changed 3 years ago by vipsoft (robocoder)

Should there be a check for if($this->applyFilterRecursively) ?

comment:2 Changed 3 years ago by matt (mattab)

I'm not sure what the problem is, but it seems related to #2133 somehow. Annoying bugs for sure, so hard to debug

comment:3 Changed 3 years ago by matt (mattab)

(In [4169]) Refs #2218 Thanks for the tip Anthon, it helped me see the light...
Now the filter object itself will take care of applying recursively when the table was recursively loaded indeed.
Leaving open until I can check that all occurences on demo are fixed

comment:5 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed that error is fixed

comment:6 Changed 3 years ago by matt (mattab)

  • Priority changed from critical to normal
Note: See TracTickets for help on using tickets.