Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2223 closed Bug (fixed)

Bing Images Search URL is wrong

Reported by: p Owned by: vipsoft
Priority: low Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description

Regarding "List of Keywords" | "Keyword" | "Search Engine" | "Bing Images" the link to Bing Image Search is wrong.

Current version is http://www.bing.com/images/search/search?q=tuttlingen+landschaft

But the right version is http://www.bing.com/images/search?q=tuttlingen+landschaft

So one "search/" is too much!

Change History (5)

comment:1 Changed 3 years ago by SteveG (sgiehl)

  • Milestone set to 1.3 - Piwik 1.3

comment:2 Changed 3 years ago by vipsoft (robocoder)

  • Keywords Bing Images Search removed
  • Owner set to vipsoft

comment:3 Changed 3 years ago by SteveG (sgiehl)

the problem is in http://dev.piwik.org/trac/browser/trunk/plugins/Referers/functions.php#L98

Bing Images has path included in the url bing.com/images/search, so the function mentioned above doesn't use the correct parameters. It uses 'search?q={k}' defined for bing.com

comment:4 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4182]) fixes #2223

comment:5 Changed 3 years ago by vipsoft (robocoder)

(In [4183]) refs #2223 - remove debug

Note: See TracTickets for help on using tickets.