Opened 3 years ago

Closed 3 years ago

#2242 closed Bug (fixed)

VisitorGenerator: Warning: uasort() The argument should be an array in core\Menu\Abstract.php on line 151

Reported by: matt Owned by:
Priority: major Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description

AFter generating visits in the Admin UI, I get the following message

Warning: uasort() [<a href='function.uasort'>function.uasort</a>]: The argument should be an array in D:\piwik\svn\trunk\core\Menu\Abstract.php on line 151

Backtrace -->
#0 Piwik_ErrorHandler(2, uasort() [<a href='function.uasort'>function.uasort</a>]: The argument should be an array, D:\piwik\svn\trunk\core\Menu\Abstract.php, 151, Array ([this] => Piwik_Menu_Admin Object ([] => ,[] => Array ([0] => Array ([0] => CorePluginsAdmin_MenuPlugins,[1] => ,[2] => Array ([module] => CorePluginsAdmin,[action] => index),[3] => ,[4] => 7),[1] => Array ([0] => CoreAdminHome_MenuGeneralSettings,[1] => ,[2] => Array ([module] => CoreAdminHome,[action] => generalSettings),[3] => ,[4] => 6),[2] => Array ([0] => UsersManager_MenuUsers,[1] => ,[2] => Array ([module] => UsersManager,[action] => index),[3] => ,[4] => 3),[3] => Array ([0] => UsersManager_MenuUserSettings,[1] => ,[2] => Array ([module] => UsersManager,[action] => userSe [...]

Change History (10)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4271]) fixes #2242 - fix VisitorGenerator

comment:2 Changed 3 years ago by vipsoft (robocoder)

  • Summary changed from Warning: uasort() The argument should be an array in core\Menu\Abstract.php on line 151 to VisitorGenerator: Warning: uasort() The argument should be an array in core\Menu\Abstract.php on line 151

comment:3 Changed 3 years ago by vipsoft (robocoder)

(In [4275]) fixes #2247 - set cip; refs #2242 - remove redundant checktokenauthinurl as we already have checkuserissuper and nonce

comment:4 Changed 3 years ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

If I generate visits, I still get the error - do you not get it?

Warning: uasort() [<a href='function.uasort'>function.uasort</a>]: The argument should be an array in D:\piwik\svn\trunk\core\Menu\Abstract.php on line 155

comment:5 Changed 3 years ago by vipsoft (robocoder)

Sounds like "svn up" didn't pick up the change in http://dev.piwik.org/trac/changeset/4275#file0.

comment:6 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from reopened to closed

OK I just tried again and saw the error, then I tried again and didn't see the error. Not sure what happened!

comment:7 Changed 3 years ago by vipsoft (robocoder)

In [4335] by vipsoft, refs #2242 - coding style

(Is the commit hook not working anymore?)

comment:8 Changed 3 years ago by vipsoft (robocoder)

  • Resolution fixed deleted
  • Status changed from closed to reopened

WTF? I just saw the error again, but now I can't reproduce it. Somehow, it forgets that I'm superuser.

comment:9 Changed 3 years ago by vipsoft (robocoder)

(I would have expected at least the personal settings menu to be displayed.)

comment:10 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4367]) fixes #2242 - ME HATE BUGS! ME SMASH BUGS! DIE BUG DIE!

Note: See TracTickets for help on using tickets.