Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2246 closed Bug (fixed)

Installer to check for pack() function available

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description

Error from forum http://forum.piwik.org/read.php?2,74303

Warning: pack() has been disabled for security reasons in /srv/www/sbs-feintechnik.com/www2/htdocs/statistik/plugins/AnonymizeIP/AnonymizeIP.php on line 52 

so, we should test that pack is enabled during install and throw a critical error if not

Change History (2)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4274]) fixes #2246

comment:2 Changed 3 years ago by matt (mattab)

(In [4282]) pack() is actually required for Core as well (converts the hexadecimal id to binary) refs #2246

Note: See TracTickets for help on using tickets.