Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2319 closed Bug (fixed)

search engines shown among external web sites

Reported by: paolobenve Owned by:
Priority: normal Milestone: Piwik 1.3
Component: Core Keywords:
Cc: Sensitive: no

Description (last modified by vipsoft)

1.2.1
The following search engines results are shown among external web sites (xxxxxx is the search string):

- it.bing.com/search?q=xxxxxx
- it.bing.com/images/search?q=xxxxxx
- www.google.it/search?as_q=xxxxxx
- www.google.it/imgres?q=xxxxxx
- www.google.com/imgres?q=xxxxxx
- search.babylon.com/web/xxxxxx
- start.facemoods.com/results.php?s=xxxxxx
- www.google.com.br/search?as_epq=xxxxxx
- www.google.com.br/imgres?q=xxxxxxx
- search.magentic.com/?q=xxxxxx
- search.searchcompletion.com/?q=xxxxxx
- mobile.virgilio.it/micro/canali/search/index.jsp?qrs=xxxxxx
- www.google.de/search?as_q=xxxxxx
- search.foxtab.com/?q=xxxxxx
- us.yhs4.search.yahoo.com/yhs/search;_ylt=A0oG7qCW9ZhNdFQAuTQPxQt.?q=xxxxxxx
- images.google.ru/imglanding?q=xxxxxx
- search.mywebsearch.com/mywebsearch/GGmain.jhtml?searchFor=xxxxxx
- mws.ask.com/mywebsearch/AJmain.jhtml?searchfor=xxxxxx
- www.google.ch/imgres?q=xxxxxx
- images.google.com/imgres?q=xxxxxxx
- www.google.fr/search?as_epq=xxxxxx
- www.astroburn-search.com/bar?q=xxxxxx
- search.offerbox.com/en/results/?q=xxxxx
- www.gooofullsearch.com/result-red.php?Keywords=xxxxxx
- isearch.babylon.com/home?q=xxxxxx
- www.cercato.it/?q=xxxxxx

Change History (9)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Description modified (diff)
  • Milestone set to 1.3 - Piwik 1.3

These are fixed in #2284:

  • it.bing.com/search?q=xxxxxx
  • it.bing.com/images/search?q=xxxxxx

comment:2 Changed 3 years ago by vipsoft (robocoder)

From what I've observed, there are cases where the Google referrer is empty. In the "Web Sites" widget, what is the URL when you view the subtable under Google? If empty (ie no keywords) then this is the expected behaviour.

comment:3 Changed 3 years ago by vipsoft (robocoder)

Added 3 weeks ago:

  • search.foxtab.com

comment:4 Changed 3 years ago by vipsoft (robocoder)

Added since 1.2.1:

- it.bing.com/search?q=xxxxxx
- it.bing.com/images/search?q=xxxxxx
- search.foxtab.com/?q=xxxxxx

Existing. Need more info:

- www.google.it/search?as_q=xxxxxx
- www.google.it/imgres?q=xxxxxx
- www.google.com/imgres?q=xxxxxx
- www.google.com.br/search?as_epq=xxxxxx
- www.google.com.br/imgres?q=xxxxxxx
- www.google.de/search?as_q=xxxxxx
www.google.ch/imgres?q=xxxxxx
- images.google.com/imgres?q=xxxxxxx
- www.google.fr/search?as_epq=xxxxxx
- images.google.ru/imglanding?q=xxxxxx

To be reviewed:

- us.yhs4.search.yahoo.com/yhs/search;_ylt=A0oG7qCW9ZhNdFQAuTQPxQt.?q=xxxxxxx
- search.babylon.com/web/xxxxxx
- start.facemoods.com/results.php?s=xxxxxx
- search.magentic.com/?q=xxxxxx
- search.searchcompletion.com/?q=xxxxxx
- mobile.virgilio.it/micro/canali/search/index.jsp?qrs=xxxxxx
- search.mywebsearch.com/mywebsearch/GGmain.jhtml?searchFor=xxxxxx
- mws.ask.com/mywebsearch/AJmain.jhtml?searchfor=xxxxxx
- www.astroburn-search.com/bar?q=xxxxxx
- search.offerbox.com/en/results/?q=xxxxx
- www.gooofullsearch.com/result-red.php?Keywords=xxxxxx
- isearch.babylon.com/home?q=xxxxxx
- www.cercato.it/?q=xxxxxx

comment:5 Changed 3 years ago by vipsoft (robocoder)

(In [4481]) refs #2319, refs #2283 - less strict on the parameter match for Google Advanced search

- www.google.it/search?as_q=xxxxxx
- www.google.com.br/search?as_epq=xxxxxx
- www.google.de/search?as_q=xxxxxx
- www.google.fr/search?as_epq=xxxxxx

comment:6 Changed 3 years ago by vipsoft (robocoder)

Rejecting these for now because the keyword parameter (q=xxxxxx) is expected to be encoded in the 'prev' parameter, and I'm unable to generate a search where the keyword parameter is not encoded.

- www.google.it/imgres?q=xxxxxx
- www.google.com/imgres?q=xxxxxx
- www.google.com.br/imgres?q=xxxxxxx
- www.google.ch/imgres?q=xxxxxx
- images.google.com/imgres?q=xxxxxxx
- images.google.ru/imglanding?q=xxxxxx

comment:7 Changed 3 years ago by vipsoft (robocoder)

Deferred to #2304

  • us.yhs4.search.yahoo.com/yhs/search;_ylt=A0oG7qCW9ZhNdFQAuTQPxQt.?q=xxxxxxx
  • search.babylon.com/web/xxxxxx

Site not responding:

  • astroburn-search.com

comment:8 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4482]) fixes #2319

comment:9 Changed 3 years ago by vipsoft (robocoder)

(In [4484]) refs #2319 - remove duplicate

Note: See TracTickets for help on using tickets.