Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2346 closed Bug (fixed)

Conversion rate per Referrer can vary from the sum of conversions of each goal

Reported by: matt Owned by:
Priority: normal Milestone: 1.4 - Piwik 1.4
Component: Core Keywords:
Cc: Sensitive: no

Description (last modified by matt)

See report in the forums

In 1.3, we now attribute Goals correctly to Campaigns. As a result, it is possible that a user arrives via a Campaign on the site, and converts a Goal, but actually the Goal was attributed to a previous campaign (used by the visitor 1 hour ago, or 10 days ago).

There is now a discrepency between:

  • global conversion rate, processed by "visits converted / visits"
  • and sum of individiual goal conversions / visits

The problem is that, for Referrers, we cannot compute and display the Global Conversion Rate. So we should only display, individual conversion rates.

Change History (3)

comment:1 Changed 3 years ago by matt (mattab)

  • Description modified (diff)

comment:2 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [4525]) Fixes #2346

  • Do not display Conversion rate from "All columns" view, when there is "per goal" metric available
  • Do not display conversion rate on the "Goals" view
  • Remove nb_visits_converted from the API when there is "per goal" metric
  • Revenue per visit, is now based on the sum of revenue for all goals, rather than trusting the "revenue" field in the visit (in case Goal Revenue was attributed to a Referrer that is different from the visit Referrer where this conversion occurred)

API Breaking: nb_visits_converted not already in response anymore (only when there is no "per goal" metrics for this report)

comment:3 Changed 3 years ago by matt (mattab)

(In [4603]) Refs #2346 reverting my big regression in metadata output in [4525]: LOOK carefully at bloody test you fool!!

Note: See TracTickets for help on using tickets.