Opened 3 years ago

Closed 3 years ago

#2360 closed Bug (fixed)

Updating pdf report with emailMe=0 throws SQLSTATE[HY000]: General error: 1366 Incorrect integer value: '' for column 'email_me' at row 1

Reported by: JulienM Owned by:
Priority: normal Milestone: 1.4 - Piwik 1.4
Component: Core Keywords:
Cc: Sensitive: no

Description

On Windows 7x64, PHP 5.3.5, MySQL 5.5.9 x64, updating a pdf report with emailMe=0 fails and gives :

SQLSTATE[HY000]: General error: 1366 Incorrect integer value: '' for column 'email_me' at row 1

The problem seems to be located at plugins/PDFReports/API.php#L105.

In the API call, when

  • emailMe=false, (bool)$emailMe is equal to true (no SQL error is thrown)
  • emailMe=0, (bool)$emailMe is equal to false (a SQL error is thrown)
  • emailMe=true, (bool)$emailMe is equal to true (no SQL error is thrown)
  • emailMe=1, (bool)$emailMe is equal to true (no SQL error is thrown)

When using the PDFReport UI and unticking the email me checkbox, the request to the API is made with emailMe=0 and displays the SQL error. Same is true for plugins/PDFReports/tests/PDFReports.test.php#L131

Change History (7)

comment:2 Changed 3 years ago by vipsoft (robocoder)

  • Milestone set to 1.4 - Piwik 1.4

isn't the first case also a problem?

Does Snover's July '09 patch work? (We won't be upgrading to ZF2 because it requires php 5.3 features.)

comment:4 Changed 3 years ago by JulienM (JulienMoumne)

The patch for Zend Framework does work but not in all cases.

When an insert statement is cached core/Db/Adapter/Pdo/Mysql.php#L182, it does not go through core/Db/Adapter/Pdo/Mysql.php#L193, hence, doesn't go through libs/Zend/Db/Adapter/Pdo/Abstract.php#L228 where the patch is applied.

comment:5 Changed 3 years ago by matt (mattab)

(In [4551]) Refs #2360 does this fix it Julien? on my box it works before so I cant tell

comment:6 Changed 3 years ago by JulienM (JulienMoumne)

This patch works. Shouldn't this be done in a more generic way ?

Also, (int)'true' equals 0, but I guess it's ok.

comment:7 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

It should, but if the bug is in Zend there is not much we can do appart from submitting them the patch ;-)

Note: See TracTickets for help on using tickets.