Opened 3 years ago

Closed 3 years ago

#2663 closed Bug (fixed)

Middle click (open in a new tab) should work as expected for menus, website selector

Reported by: matt Owned by: SteveG
Priority: major Milestone: 1.6 Piwik 1.6
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

Usability improvement: the middle click button (open in new tab) should work nicely on the website selector, and the main menu.

  • Currently, middle click on website selector opens in a new table for example "javascript:broadcast.propagateNewPage(%20'idSite=13');"
  • Middle click on the menu opens the dashboard in a new tab, instead of clicked menu

I'm not sure the best way to handle this, hopefully we can refactor the javascript code to generate the URL and have it returned onclick?

Change History (11)

comment:1 Changed 3 years ago by SteveG (sgiehl)

  • Owner set to SteveG

comment:2 Changed 3 years ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5173]) fixes #2663 middle click for open in new tab didn't work because of incorrect href attributes and javascript events bound with jquery. now working in most browsers except of IE 9 (seems to be a known bug)

comment:3 Changed 3 years ago by SteveG (sgiehl)

  • Milestone changed from 1.7 Piwik 1.7 to 1.6 Piwik 1.6

comment:4 Changed 3 years ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for small feedback: when opening "website selector" in new tab, can it also restore 'date' 'period' parameters? I'm thinking use case: website 1 is decreasing for this custom range, check other websites in a new tab for same pattern .

thanks!

comment:5 Changed 3 years ago by SteveG (sgiehl)

Should it also restore the current view? atm it always switches back to dashboard...

comment:6 Changed 3 years ago by SteveG (sgiehl)

(In [5174]) refs #2663 fixed urls in site selection, now date und period is restored on middle click

comment:7 Changed 3 years ago by matt (mattab)

Agreed, should set the same view again, I think most users will click on other views and it is less tiring for the brain :)

comment:8 Changed 3 years ago by SteveG (sgiehl)

(In [5175]) refs #2663 update links in site selection with current view, date and period params

comment:9 Changed 3 years ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 Changed 3 years ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening as I found a bug. When visiting the API page: http://localhost/trunk/index.php?module=API&action=listAllAPI&period=week&date=today&idSite=3

a left click on the website selector now reloads the page AND shows the selector, instead it should not reload the page but only show the selector as before. I thought the regression was maybe linked to these changes?

comment:11 Changed 3 years ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5201]) fixes #2663 fixes problem on api page

Note: See TracTickets for help on using tickets.