Opened 3 years ago

Closed 3 years ago

#2667 closed Bug (fixed)

Remove "visits" from Custom Variables names report since it is incorrect

Reported by: matt Owned by:
Priority: normal Milestone: 1.6 Piwik 1.6
Component: Core Keywords:
Cc: Sensitive: no

Description

Custom Variables are aggregated by 2 dimensions (name, value) therefore the count of visits for the first dimension: name, is not correct (since it sums visits for value1 and value2).

Reproduce:

  • Track customVariablePageValue1 = A and customVariablePageValue1 = B (two actions)
  • The CustomVariables report shows one visit for value A and one for value B. But the aggregated value of visits is two (which should be one). -> Two visits instead of one.

Change History (2)

comment:1 Changed 3 years ago by matt (mattab)

  • Milestone changed from 1.7 Piwik 1.7 to 1.6 Piwik 1.6

comment:2 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5235]) Fixes #2667

  • Stop aggregating visits for Custom variables of scope "page"
    • still OK for scope "visit" since there is supposed to be one custom var value per custom variable name for a given visit
  • Now we always display the Actions columns so that these rows with no visit still show the number of Actions
  • cleaned up from custom var output report, removed some "price_viewed" column left out

UI Change (future FAQ maybe...)

  • When there is a "Visits" column for the Custom Variable report with a value of "-" (hyphen) then it means this custom variable was used with scope=page.

Fixes #2662

  • Added integration tests testing getPageUrl with multiple periods and websites
  • fixed a bug when idSite=all or 1,2,3
Note: See TracTickets for help on using tickets.