Opened 3 years ago

Closed 3 years ago

#2668 closed New feature (fixed)

Usability: when period is week for example, hover in the calendar highlight all days in the week

Reported by: matt Owned by: SteveG
Priority: normal Milestone: 1.6 Piwik 1.6
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

When a non day period is selected (week for example), the calendar should highlight the day of this period. When the user hovers a day in the month it should highlight all days in the week.

This will make the calendar a lot easier to use and more classy!

Attachments (1)

week highlight stop saturday.PNG (24.2 KB) - added by matt 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by SteveG (sgiehl)

  • Owner set to SteveG

comment:2 Changed 3 years ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5178]) fixes #2668 highlight week or complete month if period is week/month/year

comment:3 Changed 3 years ago by SteveG (sgiehl)

  • Milestone changed from 1.7 Piwik 1.7 to 1.6 Piwik 1.6

comment:4 Changed 3 years ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

I reopen for a slightly unrelated bug, but the week view sometimes doesn't highlight the sunday and stops at saturday, see screenshot - do you mind taking a look? thx!

comment:5 Changed 3 years ago by matt (mattab)

Going in August then the day Aug 28 Sunday is highlighted showing that the highlight is offset by 1 day wrongly

comment:6 Changed 3 years ago by SteveG (sgiehl)

Matt, I can't reproduce that bug. There is one case a sunday is not highlighted as selected, and that is when the sunday of selected "week" is the current day.

Does that bug always occur in your case or just sometimes? Maybe the week calculation fails in some cases. Maybe at a speical time or day... or timezone?

comment:7 Changed 3 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from reopened to closed

Good point! i only see the issue with gmt-12 et gmt+12 (on my dev pc)

This ticket is therefore fixed :)

I noticed a little bug in the menu, that now the first submenu is not orange when clicking on the main menu ?

Note: See TracTickets for help on using tickets.