Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2679 closed Bug (fixed)

Allow JSONP parameter name to be either "callback" or " jsoncallback"

Reported by: Eric Owned by:
Priority: normal Milestone: 1.6 Piwik 1.6
Component: Core Keywords:
Cc: Sensitive: no

Description

Why do we require "jsoncallback=?" and not just the "callback=?" that jQuery defaults to? It would be a lot easier on new developers if their jQuery calls just worked instead of having to append an extra hash.

Change History (7)

comment:1 Changed 3 years ago by vipsoft (robocoder)

  • Milestone set to Feature requests
  • Summary changed from jsoncallback AND callback to JSONP parameter name: jsoncallback vs. callback

JSONP doesn't dictate the parameter name. But I suspect when jsonp support was added, the parameter name didn't default to "callback". (Today, this appears to de facto with jquery, dojo, and extjs.)

I'm guessing we would have to make this configureable since it is a potential compat buster.

comment:2 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5216]) fixes #2679 - use de facto standard "callback" for the JSONP callback parameter name

comment:3 Changed 3 years ago by vipsoft (robocoder)

  • Milestone changed from Feature requests to 1.6 Piwik 1.6

comment:4 Changed 3 years ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from New feature to Bug

changeset not BC, we should read both jsoncallback and callback parameter for BC

comment:5 Changed 3 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5221]) fixes #2679 - fallback to jsoncallback (BC)

comment:7 Changed 3 years ago by vipsoft (robocoder)

  • Summary changed from JSONP parameter name: jsoncallback vs. callback to Allow JSONP parameter name to be either "callback" or " jsoncallback"
Note: See TracTickets for help on using tickets.