Opened 2 years ago

Closed 2 years ago

#2847 closed Bug (fixed)

piwik.js: setDoNotTrack() broken

Reported by: madjid Owned by:
Priority: normal Milestone: 1.7 Piwik 1.7
Component: Core Keywords:
Cc: Sensitive: no

Description

Hi,
I'm using Firefox 9.0.1 with default setting and Piwik 1.6 French version.
I can't see my visits in log visiteur with this browser and maybe with precedent version ( today i've the latest).

Change History (4)

comment:1 Changed 2 years ago by SteveG (sgiehl)

  • Milestone set to 1.7 Piwik 1.7

I can't reproduce your problem with firefox 9.0.1 running on win7. In my piwik 1.6 installation all visitors of the selected day are displayed correctly. Would you mind to describe the problem a bit more detailed?

  • Are there any javascript errors occuring
  • is the page displayed correct eg. is only the list of visitors empty?
  • Might it be possible that your page just didn't have any visitors on the day selected in date choooser?

comment:2 Changed 2 years ago by madjid

My firefox is running on XP.
There is no javascript error and the piwik code is well present in the displayed page.
The list of visitors is not empty: no log only from my firefox 9.0.1 browser.
From the same machine with IE, I haven't problem.

comment:3 Changed 2 years ago by vipsoft (robocoder)

Normally, I would close this and direct the reporter to post the question in the forum.

In this case, please email us at hello (at) piwik.org with your web site url, piwik url, and login id+password to your piwik instance. And please include a reference to this ticket.

comment:4 Changed 2 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Firefox 9.0.1 to piwik.js: setDoNotTrack() broken

The problem is that you're using setDoNotTrack. This is currently broken in 1.6 because Mozilla didn't implement it as they originally spec'd it. They have now updated the documentation to reflect the as-is implementation, and we have fixed this in trunk for the upcoming 1.7 release. [5591], [5592]

Download the latest version of piwik.js from: http://dev.piwik.org/trac/export/5664/trunk/piwik.js

Note: See TracTickets for help on using tickets.