Opened 2 years ago

Closed 2 years ago

#2851 closed Bug (fixed)

Force close in Visitor Log

Reported by: smatter Owned by: tsteur
Priority: normal Milestone: Piwik Mobile Client
Component: Core Keywords: Force close, Visitor Log, HTC Desire
Cc: Sensitive: no

Description

Strange behavior: My HTC Desire is having problems with the latest release of this app. From the start screen, if I open the Visitor Log, I get the standard list of users as is normal. I can then view one of the users by opening the entry (all of this is normal until now).

Here's where it gets weird. When I return to the main window of the Visitor Log, the app randomly force closes. Sometimes it happens after the first "visitor view", sometimes after the third, or fourth (rarely do I make it further). But it's completely random. At some point, when backing out of a user view back to the main Visitor Log screen, the app crashes.

This behavior did not occur in the previous version of the app.

Here's my info:

android 2.2.2 HTC Desire
Version: 1.6.2 - 1.8.0 74940df
Available memory: 593496
Resolution: 400x800 high (240)
Locale: en-AT
Network: Mobile

(this happens if connected to either mobile or WiFi)

Great app, gonna dig around and see if I can find the previous version and install that instead.

Change History (6)

comment:1 Changed 2 years ago by tsteur

Hi smatter,

I was able to reproduce it in simulator. In most cases I was able to force an OutOfMemory Error. Do you get the message "Activity Piwik Mobile is not responding"?

Just once I could force another error where I got another error message (it was not an OutOfMemory Error). But was not able to reproduce it again.

comment:2 Changed 2 years ago by tsteur

Could you try Piwik Mobile 1.7 Beta? http://builds.piwik.org/Piwik_Mobile_1.7b1.apk
I'm not sure whether it is better in this version but runs fine on Samsung Galaxy S2

comment:3 Changed 2 years ago by tsteur

(In [5765]) refs #2851 Removed nearly all memory leaks, at least on iOS. Nearly no memory was released before by the garbage collector. Also removed Ti.App event listeners where possible. They run in a global app context causing they will never be released. On Android, I don't see any memory release in DDMS at the moment. Possibly due to these Titanium issues http://jira.appcelerator.org/browse/TIMOB-4367 http://jira.appcelerator.org/browse/TIMOB-7409 https://jira.appcelerator.org/browse/TIMOB-6380 . I'll keep an eye out for it.

comment:4 Changed 2 years ago by tsteur

(In [5773]) refs #2851 removed more memory leaks. Garbage collector does now also free memory on Android when using latest Titanium Mobile 1.9.0 build. Was not able to reproduce a force close in Simulator

comment:5 Changed 2 years ago by tsteur

  • Owner set to tsteur
  • Status changed from new to assigned

comment:6 Changed 2 years ago by tsteur

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed in Piwik Mobile 1.7 . Please reopen if not.

Note: See TracTickets for help on using tickets.