Opened 2 years ago

Closed 2 years ago

#2950 closed Bug (fixed)

Email reports sent with web cron are not sent in the user language

Reported by: matt Owned by:
Priority: normal Milestone: 1.7.x - Piwik 1.7.1
Component: Core Keywords:
Cc: Sensitive: no

Description

They seem to be sent in the visitor's triggering web cron language.

At least 3 users reported receiving reports in random languages every day.

Change History (3)

comment:1 Changed 2 years ago by matt (mattab)

I cant reproduce this. I created a new user, the report is sent in the users's language. I deleted the user language from user_language table. Then generated the report using japanese browser. Report is sent in english. Maybe this was fixed as a side effect of #2960 ?

comment:2 Changed 2 years ago by matt (mattab)

Actually I can reproduce. Will work on a fix

comment:3 Changed 2 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5903]) Fixes #2950

Note: See TracTickets for help on using tickets.