Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#2984 closed Bug (fixed)

archive.php does not archive weeks/month/year in some cases on low traffic websites

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.8
Component: Core Keywords:
Cc: Sensitive: no

Description

Reported in forum post. Small bug in archive.php

Change History (5)

comment:1 Changed 2 years ago by matt (mattab)

(In [5927]) Refs #2984

  • Force archive periods for websites that we know should be archived (ie. when the day is finished in their timezones)

comment:2 Changed 2 years ago by matt (mattab)

Also in forums

Yes I kept piwik up to date, in the hope it would be fixed someday. Before it was still tracking the pages (I could see the tables fill up) but the piwik interface didn't display anything of data. After DST went in effect, visits showed up again in the interface. 

The piwik data misteriously shows up after DST time changes. This is very strange. There is a bug of some sort in the archive selection code for sure!

==> See forum post for debug info

Also ping lorieri when bug is found

comment:3 Changed 2 years ago by matt (mattab)

  • Milestone changed from 1.7.x - Piwik 1.7.x to 1.7.2 - Piwik 1.7.2

comment:4 Changed 23 months ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [6415]) Fixes #2984 Thanks loriero for this very hard to find bug fix and patch!!

Please report any other issue you may experience with archive.php and zero visit days

comment:5 Changed 23 months ago by matt (mattab)

(In [6416]) Refs #2984 Deleting the "lock" records once the archive is processed since they are not useful. Thanks Jenkins for the hint!

Note: See TracTickets for help on using tickets.