Opened 2 years ago

Closed 13 months ago

Last modified 12 months ago

#2987 closed Bug (fixed)

Dashboard: including "Last visits graph" and "Overview with graph" widgets at the same time causes one graph not to load

Reported by: matt Owned by: capedfuzz
Priority: major Milestone: 1.12 - The Great 1.x Backlog
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

See screenshots. There is a problably a JS conflict when trying to write to the graph DOM node, probably because they have the same ID "VisitsSummarygetEvolutionGraph"

Attachments (3)

one graph displayed only.png (39.2 KB) - added by matt 2 years ago.
both-graphs-showing.png (201.3 KB) - added by james 12 months ago.
Screenshot of both graphs co-existing
one-graph-fails.png (191.2 KB) - added by james 12 months ago.
Screenshot of one graph failing when a metric is added

Download all attachments as: .zip

Change History (9)

comment:1 Changed 23 months ago by capedfuzz (diosmosis)

(In [6354]) Refs #3137, #2987, reverted datatable id changes, will require much more work to fix this bug.

comment:2 Changed 21 months ago by matt (mattab)

  • Owner set to capedfuzz

comment:3 Changed 13 months ago by matt (mattab)

  • Milestone changed from 1.12.x - Piwik 1.12.x to 1.12 - Piwik 1.12
  • Priority changed from normal to major

comment:4 Changed 13 months ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

13 months old bug, fixed in git, Nice!! :)

Changed 12 months ago by james

Screenshot of both graphs co-existing

Changed 12 months ago by james

Screenshot of one graph failing when a metric is added

comment:5 Changed 12 months ago by james

matt, I've added screenshots of the bug I'm experiencing. Is this the same bug, and will this behavior also be fixed in 1.12?

The issue is that both graph co-exist until I add another metric to one of the graphs, like the Pageviews metric, then the graph fails. You'll see in the screenshots Visits Overview (with graph) fails when I try to add Pageviews to it.

comment:6 Changed 12 months ago by capedfuzz (diosmosis)

Hi @james, looks like it's working on the demo (demo.piwik.org), so it should be fixed in 1.12.

Note: See TracTickets for help on using tickets.