Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3055 closed Bug (fixed)

mixed columns in API.get resultset

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 1.8
Component: Core Keywords:
Cc: Sensitive: no

Description

Reported in the forums

Column names in Piwik Export Files (TSV Excel) is not correct. 

Steps to reproduce:
1.) Goto Visitors > Overview
2.) Select "month" in period selection (IMPORTANT)
3.) Click on save icon and select TSV Excel and download report

The report will show more Unique outlinks than outlinks. It also shows more Unique Pageviews than Downloads which is very uncommon. [Of course there are a lot of 0 in columns because piwik got new metrics in 1.7] 

  • we should add test highlighting this bug
  • and fix the issue, which might be related to #2765 ?

Change History (3)

comment:1 Changed 2 years ago by matt (mattab)

  • Milestone changed from 1.7.x - Piwik 1.7.x to 1.7.2 - Piwik 1.7.2

comment:2 Changed 2 years ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [6276]) Fixes #3055, fixed bug with CSV Renderer where column order was not kept constant when rendering DataTable_Arrays. Also modified OneVisitorTwoVisits test by adding more outlink actions and one CSV test.

comment:3 Changed 2 years ago by matt (mattab)

(In [6305]) Refs #3055 small refactor - thanks capedfuzz for your patch!

Note: See TracTickets for help on using tickets.