Opened 2 years ago

Closed 2 years ago

#3139 closed New feature (fixed)

Allow tracking request to record googlebot/bing bot requests

Reported by: rch Owned by:
Priority: normal Milestone: Piwik 1.8
Component: Core Keywords: bot image tracker bottracker
Cc: Sensitive: no

Description

Currently the Piwik Image Tracker allows only to count real visitors. However for seo practionners it can be very useful to know if bots are visiting specific websites where we are putting advertisement on it.
I think it could be very interesting to have a specific Image Tracker to track bots or to use the existing BotTracker plugin to take into consideration bots coming from Image Tracker.

Change History (2)

comment:1 Changed 2 years ago by matt (mattab)

  • Component changed from New Plugin to Core
  • Milestone changed from Piwik Mobile Client to 1.7.2 - Piwik 1.7.2
  • Summary changed from Image Tracker for BotTracker to Allow tracking request to record googlebot/bing bot requests

This is also a problem with the log import script

This is caused by code in: http://dev.piwik.org/trac/browser/trunk/core/Tracker/Visit.php#L686

This code automatically discards all requests from googlebot or bing bot. Instead we should allow to record these requests for example by adding a &bots=1 to the request.
The python script would also need to pass &bots=1 when --enable-bots is set.

Then you would only have to add &bots=1 to the image tracker to allow tracking of bots.

However we will still need a way to track which bots access what content. So maybe we could set a custom variable with the user agent when &bots=1 ?

comment:2 Changed 2 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [6403]) Fixes #3139 Adding new 'bots' parameter to the Tracking API. When set to 1 Piwik will record the request even if it is made by a bot (currently detected are only Googlebot and some Bing bots)

Refs #703 - Cyril, when --enable-bots is set, can you please make sure the parameter &bots=1 is also set to piwik.php request? only in this case though. Thanks!

Note: See TracTickets for help on using tickets.