Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#322 closed Task (fixed)

Update the graph library to use Open Flash Chart V2

Reported by: matt Owned by:
Priority: normal Milestone: Piwik 0.6.1
Component: Core Keywords:
Cc: mauser Sensitive:

Description (last modified by matt)

We are currently using OFC version 1.
It does a great job for us.

However the development is now focused on OFC v2 and we want to update the code to use this newer library.

The new library uses json format instead of the current obscure non standard format.

When update is done, see also #624
Also once update is done we can consider other graphs improvements: #532

Change History (15)

comment:1 Changed 5 years ago by matt (mattab)

  • Description modified (diff)

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Owner set to vipsoft

See ticket #243 for swfobject update.

comment:3 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from DigitalVibes to RobotRock
  • Priority changed from major to normal
  • Type changed from Bug to Task

comment:4 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from RobotRock to DigitalVibes
  • Owner vipsoft deleted

comment:5 Changed 5 years ago by vipsoft (robocoder)

Currently, with OFC1 pie charts, hovering over a pie slice displays the truncated label in the tooltip. Example: "Gecko (Mozilla - Net..." followed by the count.

The problem observed in ticket #243 where the "Loading data..." would appear in the upper left corner of the div (in Firefox) is spurious in IE and not reproduceable in Safari. The OFC2 examples use the newer swfobject and do not display this problem, so it is expected this anomaly will disappear with the update to OFC2.

comment:6 Changed 5 years ago by vipsoft (robocoder)

In ticket #243, I updated swfobject; however, I didn't make use of the added support for when Flash isn't installed. Following is consolidated from ticket #542:

Last few days I've been in contact with someone who was using MediaWiki's Piwik Integration extension, of which I am the author. That extension makes use of the widgetize plugin, and it'd be great if a message appeared saying flash is needed to see the graphs (only if flash isn't installed).

comment:7 Changed 5 years ago by mauser (zawadzinski)

  • Owner set to mauser
  • Status changed from new to assigned

comment:8 Changed 5 years ago by matt (mattab)

  • Description modified (diff)
  • Owner mauser deleted
  • Status changed from assigned to new

comment:9 Changed 5 years ago by mauser (zawadzinski)

  • Cc mauser added

comment:10 Changed 5 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1072]) - API CHANGE: the API for the function Piwik_AddWidget has changed. The new API is Piwik_AddWidget( $widgetCategory, $widgetName, $controllerName, $controllerAction, $customParameters = array()). See examples of calls in all the core Piwik plugins. This change was necessary to make widgets more modular (they now accept custom parameters).

  • API CHANGE: a small number of CSV outputs for some API calls would change following the simplification of DataTable_Simple implementation. Affected calls are VisitsSummary.get, Goals.get, VisitFrequency.get. This is due to a change in the implementation of DataTable_Simple (we simplified implementation).
  • FIXED #84 Added proper translations for all columns, in tables, and graphs.
  • FIXED #322 piwik is now using open flash chart 2
  • FIXED #126 all dates should be correctly displayed in all graphs. For example, evolution graph for days would show, on the X axis "Mon 29", "Wed 31". For months it would show "Aug 2009", etc.
  • ADDED: when hovering any of the sparklines, the UI makes it clear that clicking will refresh the evolution graph. This feature was in Piwik for months, and even Google Analytics implemented this UI feature after Piwik. However in Piwik it wasn't clear to the user that the sparklines were clickable.
  • ADDED: now widgets can be created with custom parameters. This makes it possible to create a widget that calls a controller->action with other custom parameters, this is used in Piwik to draw an evolution graph (module=VisitsSummary & action=getEvolutionGraph) for a given metric (&columns[]=nb_visits). These custom parameters are automatically forwarded to the sparkline url, the flash graph when clicked on sparkline, etc.
  • The widget layout is now saved as a JSON string rather than a custom data structure. The dashboard code should be able to read & restore most of the layouts from the old format (except the evolution graphs widgets). Simplified the Dashboard.js, widgetMenu.js, cleaned up what was a messy code.
  • Added sentence in Widgetize to let users know they can easily export the Piwik dashboard in an iframe.
  • Changed the way translations used in Javascript are loaded: all translations strings finishing by _js will be loaded to be used in the templates when calling {loadJavascriptTranslations plugins='YOUR_PLUGIN_NAME'}
  • Moved all templates in plugins under plugins/$PLUGIN/templates/
  • 'Khtml (Konqueror, Safari)' now displayed as 'KHTML (Safari, Chrome)'

comment:11 Changed 5 years ago by horowos

comment:12 Changed 5 years ago by horowos

comment:13 Changed 5 years ago by ywvrypca

comment:14 Changed 5 years ago by alivenk

comment:15 Changed 5 years ago by koteiko

Note: See TracTickets for help on using tickets.