Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#3281 closed Bug (fixed)

Calendar: Week is sometimes highlighted 1 day too early in the calendar only

Reported by: matt Owned by:
Priority: major Milestone: 1.8.3 - Piwik 1.8.3
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

In the calendar, there is bug that colors the week overlapping 2 weeks. See attached screenshot.

The bug is a UI bug / JS only since the data and the Date displayed are correct.

Attachments (1)

Week overlapping bug in javascript.PNG (7.6 KB) - added by matt 21 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 21 months ago by capedfuzz (diosmosis)

matt, can you confirm this bug is still there? I can't reproduce it. Though it might have something to do w/ the current day...

comment:4 Changed 21 months ago by matt (mattab)

I see the bug in chrome and FF... the date July 29 is highlighted but it's sunday of past week.
Maybe try to change timezone to GMT+12 ? can you replicate it?

comment:5 Changed 21 months ago by capedfuzz (diosmosis)

Ok, that did it, I see the bug.

comment:6 Changed 21 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [6667]) Fixes #3281, fix bug dealing w/ client timezones in period selector. Also a small optimization to period selector code.

comment:7 Changed 21 months ago by matt (mattab)

Nice to fix a 4 year old bug :)

Note: See TracTickets for help on using tickets.