Opened 21 months ago

Closed 18 months ago

Last modified 18 months ago

#3296 closed Bug (fixed)

Fatal Error in VisitSummary Widget

Reported by: SteveG Owned by: capedfuzz
Priority: normal Milestone: 1.9.1 - Piwik 1.9.1
Component: Core Keywords:
Cc: Sensitive: no

Description

Bug report via mail:


We've got an error on the dashboard, for the component which displays the number of visitor in a graph.
We get the error Fatal error: Call to a member function getFirstRow() on a non-object in /PathToWWW/piwik/plugins/VisitsSummary/Controller.php on line 115

It sometimes happen, sometimes not and we don't know why.

Change History (3)

comment:1 Changed 18 months ago by matt (mattab)

  • Milestone changed from 1.9.2 - Piwik 1.9.2 to 1.9.1 - Piwik 1.9.1
  • Owner set to capedfuzz

let's simply catch this empty datatable use case & return "No data" when the this happens, instead of php error.

comment:2 Changed 18 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7238]) Fixes #3296, check for empty datatable in VisitsSummary_Controller::setSparklinesAndNumbers.

comment:3 Changed 18 months ago by capedfuzz (diosmosis)

Note: I couldn't reproduce the bug, but [7238] should fix it.

Note: See TracTickets for help on using tickets.