#3331 closed Bug (fixed)

Can not choose in the field Web site in IE 7

Reported by: E Owned by: capedfuzz
Priority: normal Milestone: 1.9.1 - Piwik 1.9.1
Component: Core Keywords: field Web site, Internet Explorer 7 bug
Cc: Sensitive: no

Description

I have several profiles/ accounts in Piwik and before the 1.8.3 upgrade I could pick a profile in the box next to Web site. Now I can not click on any name there, nor can I type in a search for a profile. I use the browser Internet Explorer 7, but it works in FF. Still it would be great if you could fix this small bug since IE 7 is our standard browser and many do not have two browsers in my organisation. Thanks in advance!

Attachments (2)

FieldWebSite.bmp (96.1 KB) - added by E 21 months ago.
The field Web site
ie7-site-selector.patch (332 bytes) - added by pebosi 19 months ago.

Download all attachments as: .zip

Change History (7)

Changed 21 months ago by E

The field Web site

comment:1 Changed 21 months ago by matt (mattab)

  • Milestone set to 1.8.4 - Piwik 1.8.4
  • Owner set to capedfuzz

Thanks for the report

comment:2 Changed 19 months ago by pebosi

Because ul.nav has an z-index of 10, the .top_bar_sites_selector needs at least 20. Patch attached, works in IE7-9.

Changed 19 months ago by pebosi

comment:3 Changed 19 months ago by E

Great! Thanks a lot for your help!!

comment:4 Changed 18 months ago by matt (mattab)

  • Milestone changed from 1.9.2 - Piwik 1.9.2 to 1.9.1 - Piwik 1.9.1

comment:5 Changed 18 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7292]) Fixes #3331, applied pebosi's patch after confirming: use higher z-index w/ site selector.

Note: See TracTickets for help on using tickets.