Opened 18 months ago

Closed 13 months ago

Last modified 12 months ago

#3465 closed Bug (fixed)

Evolution Graph displays "no data" if last date has no data

Reported by: tsteur Owned by: capedfuzz
Priority: major Milestone: 1.12 - The Great 1.x Backlog
Component: Performance Keywords:
Cc: Sensitive: no

Description

I tried to test evolution graph with "period=range". For example from 8th August 2012 to 2nd September 2012. It renders a graph displaying "No data for this graph" if there are no visits/actions on the last day of the period. If I set range from 8th August 2012 to 3rd September 2012, it dispalys the graph. There are actions and visits in August. It seems just to depend whether there are actions/visits on the last day.

When the graph is displayed with message "No data for this graph", the graph is also loading fast. Maybe it just looks at the last day and does no further queries in this case.

Manage this edge case when there is no data. This happens with any period, not only range.

See http://dev.piwik.org/trac/ticket/3158#comment:11
and http://dev.piwik.org/trac/ticket/3158#comment:12

Change History (14)

comment:1 Changed 18 months ago by tsteur

  • Owner set to matt

comment:2 Changed 18 months ago by matt (mattab)

  • Component changed from Core to Performance
  • Milestone changed from 1.9.x - Piwik 1.9.x to 1.9.2 - Piwik 1.9.2
  • Owner changed from matt to capedfuzz
  • Priority changed from normal to major
Last edited 16 months ago by matt (previous) (diff)

comment:4 Changed 17 months ago by matt (mattab)

xhprof use is related to #3464

comment:5 Changed 14 months ago by capedfuzz (diosmosis)

In 930ec65093018c13c39091e991a4ebacd7a30ee3:

Refs #3465, use bulk tracking in RowEvolution integration test to speed it up.

comment:6 Changed 13 months ago by capedfuzz (diosmosis)

In 80ac6ac1666508cb0844dc1eac2faba303fa9f9e:

Refs #3465, remove Piwik_DataTable_Array::metadata and move data to Piwik_DataTable::metadata.

comment:8 Changed 13 months ago by JulienM (JulienMoumne)

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #3790

comment:9 Changed 13 months ago by matt (mattab)

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:10 Changed 13 months ago by matt (mattab)

@JulienM wrote in #3790:

Since 3013 the Row Evolution API can be called to retrieve the top N label evolutions.

As suggested in 3158#comment:12, when there are less than 5 labels for the requested period, "top up" the labels list by requesting the report for the current year of data.

comment:11 Changed 13 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from reopened to closed

In 51b77878acf71118e9d4cb769d72ded7bbfbf6fa:

Fixes #3465, refactor row evolution code to fix bug where if no labels are specified and last period has no labels, no data is returned. Refactoring also contains optimization for case where no labels are specified.

Notes:

  • Simplified DataTableManipulator and derived classes.
  • Allow LabelFilter to use multiple labels. Can be used by specifying array for label query parameter (ie, label[]=...).
  • Removed getFilteredTableFromLabel function from datatable types and add getEmptyClone to DataTable_Array.
  • Added setIdSite to php tracker PiwikTracker.

comment:12 Changed 12 months ago by capedfuzz (diosmosis)

In d9ff5001ecfe0fc763e62dc3a9363fc4a45d02d3:

Refs #3465, fix regression in multi row evolution API output where columns w/ value of 0 were not outputted.

comment:13 Changed 12 months ago by capedfuzz (diosmosis)

In 7a89c65378fd7893d5c0b0fdec925b870adb4ed9:

Refs #3465, make sure labels are associated with correct rows in multi-row evolution after generic filters (ie, Sort) are applied.

comment:14 Changed 12 months ago by capedfuzz (diosmosis)

In 204cbc0af2cc2914235f6a720e4a5abf0d6b4101:

Refs #3465, fix regression for flattener filter where queued filters were applied on the flattened datatable.

Note: See TracTickets for help on using tickets.