#3472 closed Bug (fixed)

Changing the dashboard doesnt work

Reported by: DH Owned by: capedfuzz
Priority: low Milestone: 1.10 - Piwik 1.10
Component: Core Keywords: settings, dashboard
Cc: Sensitive: no

Description

Hey!

I'm using Piwik 1.9 to track two sites. If you choose "All Websites dashboard" as default in the settings everything's fine. Changing back to a specific site doesn't work as long as you don't select a value by clicking the drop down. Just selecting "Dashboard for a specific website" and using the suggested site doesn't work.

Change History (2)

comment:1 Changed 18 months ago by matt (mattab)

  • Milestone set to 1.9.2 - Piwik 1.9.2
  • Owner set to capedfuzz

Thanks for the report.

The problem is that changing the setting does not update the &idSite= currently used, so the User Settings page is loaded with the previous idSite value and not the new one selected for default dashboard.

--> instead, When a new "dashboard for specific website" is to load by default, we should change the idSite in the request & menu to output link containing the new idsite.

comment:2 Changed 17 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7536]) Fixes #3472, make sure user settings uses proper site id to initialize site selector widget so save w/o actual 'click' select works.

Note: See TracTickets for help on using tickets.