#3529 closed Bug (fixed)

Piwik 1.9.1 Visitor Location (City) widget: Minor problem

Reported by: canajun2eh Owned by: capedfuzz
Priority: normal Milestone: 1.10 - Piwik 1.10
Component: Core Keywords:
Cc: Sensitive: no

Description

This is a re-post of a bug incorrectly reported in the General Questions forum.

In Piwik 1.9.1, the Visitor Location (City) widget does not behave properly under the following circumstance:

My site has GeoIP (Php) installed and enabled. When the incoming IP address is not in the GeoLite City database from MaxMind, and when that incoming connection is the only one, the Visitor Location (City) widget tells me that the GeoIP feature is not properly installed. The location of this incoming IP address is properly shown as "Unknown".

As soon as my site sees a connection from an IP address that is in the MaxMind database, the above error goes away. The location of that first IP address is, of course, still shown as "Unknown".

I suggest that the error message text be amended to include the possibility that the database is out of date (it wasn't, in my case) or to simply not produce an error message at all when the MaxMind database is present.

Change History (2)

comment:1 Changed 17 months ago by matt (mattab)

  • Milestone set to 1.9.3 - Piwik 1.9.3
  • Owner set to capedfuzz

I propose that when there is region data, but the geoip is detected as "Working" then we display the standard message "There is no data for this report", Does it sound good capedfuzz?

comment:2 Changed 16 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7629]) Fixes #3529, modify message displayed if no data in region/city reports based on whether geoip is currently working or not.

Note: See TracTickets for help on using tickets.