Opened 17 months ago

Closed 17 months ago

Last modified 15 months ago

#3543 closed Bug (fixed)

Piwik 1.9.2 dashboard and widgets don't stick

Reported by: fish11 Owned by: SteveG
Priority: major Milestone: 1.10 - Piwik 1.10
Component: Core Keywords:
Cc: Sensitive: no

Description

On a new installation of Piwik 1.9.2. After moving around the widgets on the default dashboard. Go to another tab or to the settings page. Now return to the dashboard. The layout and position of the widgets that were moved around default back to the original that came with the install. The dashboard does not save the widgets.

Example: remove the global map widget and the RSS widget. Go to a tab or settings page. Return to the dashboard and the global map widget and RSS widget are there again. Adding a new widget does the same thing. Go to another page and come back. The dashboard defaults to the original install widgets and layout.

In version 1.9.1 the dashboard customizing works and saves. In version 1.9.2 it does not. Please install a new version of 1.9.2 and see what actually works. I attempted to install 1.9.1 and was planning to update to 1.9.2 to get the dashboard with widget in a layout I like. I quickly realized the dashboard and widgets gets saved in 1.9.1 but the tracking does not work in 1.9.1. I am not sure if on a new install whether or not Piwik logs visits for 1.9.2. (Firefox was used and IE)

For future releases could you please do a new test installation to see if the dashboard/widgets save and if Piwik actually logs visits. Maybe if someone updates from a previous version it still works but from what I can tell on a brand new installation of Piwik there are some issues. Thanks a lot!

Change History (12)

comment:1 Changed 17 months ago by SteveG (sgiehl)

  • Milestone set to 1.9.3 - Piwik 1.9.3

comment:2 Changed 17 months ago by matt (mattab)

Can you please email to matt@… your piwik URL + login + password + link to this bug + steps to reproduce? I will take a look and we'll get it fixed. thanks!

comment:3 Changed 17 months ago by SteveG (sgiehl)

  • Owner set to SteveG

the problem might be, that the layout parameter is passed as GET. That might make the URL very long, causing some servers to cut them off. I'll have a look at that later and change that to a POST parameter.

comment:4 Changed 17 months ago by fish11

Please disregard the part about browser logging. It appears that may be an issue specific to how my system is setup. I'll look into what caused my browser to not get logged later. I have sent the email to you Matt. Thank you for your help Matt and Steve.

comment:5 Changed 17 months ago by matt (mattab)

  • Priority changed from normal to major

Steve I think you're right. the server returns error "<p>The parameter layout isn't set in the Request, and a default value wasn't provided"

changing to POSt should fix it thanks in advance

comment:6 Changed 17 months ago by SteveG (sgiehl)

Changed to POST params in [7489].
@fish11: you could try the latest beta and report if it works there

comment:7 Changed 17 months ago by fish11

Yes, I believe it works now. I tried piwik-1.9.3-b7. Thank you Steve.

comment:8 Changed 17 months ago by SteveG (sgiehl)

  • Resolution set to fixed
  • Status changed from new to closed

Closing this ticket for now as other users also reported that it works with latest beta. Please reopen the ticket if it should be broken within the next stable release.

Last edited 17 months ago by SteveG (previous) (diff)

comment:9 Changed 16 months ago by catorghans

Hi SteveG,

That changeset contains a lot of code.
Is it possible to give a patch for 1.9.2 that only solves this?

I don't want to risk my piwik with dozens of sites with a beta, but would very much like this bug to be solved.
(One of our bigger customers was using Google Analytics, and I was able to convince them using Piwik, until they ran into this bug. It would be a pity if they choose using Google Analytics again only because of this)

Last edited 16 months ago by catorghans (previous) (diff)

comment:10 Changed 16 months ago by matt (mattab)

please use latest beta, we don't do custom patches because beta work well :)

comment:11 Changed 16 months ago by catorghans

Thanks,

If I follow the FAQ and add

[Debug]
allow_upgrades_to_beta = 1

nothing happens.

It seems to be related to
http://builds.piwik.org/LATEST_BETA
which also says: 1.9.2

Is there a new generic way to get the latest Beta?

comment:12 Changed 15 months ago by matt (mattab)

there was a bug with beta releases now fixed!

Note: See TracTickets for help on using tickets.