Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#3550 closed Bug (fixed)

GoalManager: misspelled variable leads to incorrect attribution

Reported by: christian.futterlieb Owned by:
Priority: major Milestone: 1.10 - Piwik 1.10
Component: Core Keywords:
Cc: Sensitive: no

Description

To me it seems very likely that this is not wanted. Because with the uninitialized variable $refererCampaignName Campaign data are always taken from $visitorInformation (if $visitorInformation has a campaign registered). Please take a look at the patch.

Attachments (1)

GoalManager-3550.diff (1.1 KB) - added by christian.futterlieb 17 months ago.

Download all attachments as: .zip

Change History (4)

Changed 17 months ago by christian.futterlieb

comment:1 Changed 17 months ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7485]) fixes #3550 referrerCampaignName typo; thanks Christian

comment:2 Changed 17 months ago by matt (mattab)

  • Milestone set to 1.9.3 - Piwik 1.9.3

oh very cool find, thanks so much, this bug was reported over the last months and I never found the cause, Cheers! Please keep patches like this coming ;-)

comment:3 Changed 17 months ago by christian.futterlieb

^^ .. I'm glad to be able to give something back

Note: See TracTickets for help on using tickets.